Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

None of the above data generation error

I get the following error when generating data on multi-select questions which have an exclusive list item at the bottom. Usually called "None of the above"

Errors - "None of the Above" and another option cannot both be selected.


Why is this an error? If a list item is exclusive, by definition I don't want other options selected.

Using SSI 8.2.0

Thanks,
-Dan
asked Apr 13, 2013 by Dan Brown (145 points)

1 Answer

0 votes
I'm assuming you have made "None of the above" exclusive and when you select this code with any other options the error appears (as it should)?

Selecting any other option combinations should be okay as long as "None of the above" is not selected with them.

Make sure it is only "None of the above" that is exclusive.
answered Apr 13, 2013 by Paul Moon Platinum (60,130 points)
Thanks for replying Paul.

I think you have misunderstood my question. I'm not selecting anything, this is an error from the data generator in SSI Web 8.2.

I'm trying to run dummy data through my survey and every time the data generator gets to a multi-select question with an exclusive option it stops, throws this error and that response is counted as an incomplete.

I don't understand why the data generator thinks its an error. I would like to know a work around short of defining all the values for multi-select questions.
OK, I didn't realise it was the data generator you were using? I thought it was test mode.

This maybe a bug?
...