Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Error: Premature End of Script Headers: ciwweb.pl

Hi. Today, I had upgraded our mac server which hosts sawtooth to a newer OS (Leopard to Snow Leopard). While the upgrade went smoothly, something during the transition caused an issue with Sawtooth where we are constantly getting the error message: "Premature End of Script Headers: ciwweb.pl." This pertains to version 8.1 of Sawtooth. We also have Version 6.6 installed and that version works just fine. However, v. 8.1 is the newer one we have started using in the past few months and ever since the upgrade, we have been unable to access it.
I also created a test.pl file to make sure the file structure/permissions still worked and they did as the test.pl file executed properly. I'm not entirely sure what could be causing this issue now. I am hoping someone can shed some light on this issue.
Example of the site: http://sawtooth.kjtgroup.com/cgi-bin/v8/ciwweb.pl?studyname=J12070f&rval=1&hid_pagenum=1&hid_link=1&hid_javascript=1

Thank You!
asked Mar 21, 2013 by params (120 points)
retagged Mar 21, 2013 by Walter Williams

2 Answers

0 votes
When I check http://sawtooth.kjtgroup.com/cgi-bin/v8/ciwweb.pl?studyname=J12070&rval=1 I'm getting error 129 cannot find path file and Error writing error log.  My first hunch is that perhaps the relative pathway settings in SSI Web are not correct to reflect that you have a cgi-bin/v8 pathway perhaps?  You can change these by clicking on the Advanced button underneath the Self Hosting tab (8.2).  I would also upgrade to 8.2 first just in case an issue has already been resolved.
answered Mar 21, 2013 by Brian McEwan Gold Sawtooth Software, Inc. (38,315 points)
0 votes
Did you transfereed scripts to the hosting via some FTP/SFTP software and left it in text mode? Try binary or vice-versa..
answered Apr 16, 2013 by Mithat Bronze (4,410 points)
...