Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Sawtooth Error 102

Hi. I am hosting a survey (v7.26) where respondents are receiving the error message...

"Sawtooth Error #102" which includes the message "Study name passed is empty. Cannot find study name."

The error seems to be isolated to certain respondents - which are staff members of an organisation accessing the survey through their organisations proxy server. They can start the survey but receive the message at various points through the survey.

The same survey link was sent to all respondents and has a single password attached that can be used multiple times.

Other surveys hosted on my same server work fine, and I can access and complete the above survey no problem.

Does any-one know what may be causing the problem?

Any information appreciated.

Thanks
Russell
asked Sep 17, 2012 by rapizel Bronze (1,420 points)
retagged Sep 17, 2012 by Walter Williams

2 Answers

+2 votes
Hi,

Are you using standard permission for STUDYNAMEpwds.cgi file ( Permission 644). Also for other folder like data, admin. Use standard permission only. https://www.sawtoothsoftware.com/support/issues/ssiweb/server_setup/version_7/index.shtml Use your own server from this link and check 'Setting Permissions'.

Hope this helps.
answered Sep 17, 2012 by Rajesh Rana Gold (23,705 points)
Hi. Thanks for you answer. I did check the file permissions and all are OK - they match the recommended file permission settings. Respondents are from a government department and am guessing it has something to do with their particular work internet environment/settings???
+2 votes
Typically this error happens when someone clicks on a link and doesn't get the full pass-in link, either due to them not copying and pasting it entirely, or perhaps the text has wrapped and for some reason it's not using the full link when they click on it.

Now, that's the most likely cause.  In my experience sometimes proxy servers cause their own special problems, so I can't say for certain if it's something out of your and our hands.
answered Sep 17, 2012 by Brian McEwan Gold Sawtooth Software, Inc. (39,370 points)
HI Brian thanks for your input. Respondents can start the survey but then receive the error after answering some questions. Can you please tell me what error #102 means? Does it mean the information in the link being passed from the computer to the survey server (after the "Next" button is clicked) is incomplete in some way? ie the proxy server might be effecting/altering it? Just trying to work out what to ask their IT guy to look for.

 Is the error less likely to occur with SSI 8?

Thanks Russell
Error 102 literally means that the studyname passed in was empty.  A normal login link would be www.mysurvey.com/login.html while a login-bypass link would be www.mysurvey.com/cgi-bin/ciwweb.pl?studyname=XXXX.  Error 102 would occur when you still direct someone to the ciwweb.pl file, but the studyname part of it is wrong or blank.

I don't really understand how it can happen in the middle of a survey, but my gut reaction is something is wonky with the proxy server.  I would try to watch/record someone taking the survey and see how the URL behaves as they progress through the survey and see if that provides any insight.  You could also send in the error log from your admin module to support at sawtoothsoftware.com if you would like.
...