Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Pictures in CBC design

Hallo,
I have a CBC-Design (partial-profile, 4 attributes shown in each concept) , where each level should be showed with a short name, a picture and a scroll-over-text. Always following the same pattern.  But when I test the survey locally, I have a problem:
1. Some pictures are shown correctly and for others, I only can see a red cross.
I still have adapted the file name and replaced spaces with underscores, and some red crosses still appear???

What have I made wrong here?
asked Nov 11, 2011 by anonymous
retagged Sep 13, 2012 by Walter Williams

1 Answer

0 votes
If some are showing correctly and others are not, it would indicate that there's probably not an issue with the relative pathways or anything like that.  I always recommend breaking the problem down into its simplest parts first.  So, for a picture that is not showing, I would do something like add it a text/filler question before the conjoint exercise and just see if it displays properly by itself.  That might identify a problem with the name of the file, a syntax error in your HTML, etc.

I have also run into issues where for certain types of web servers, image.jpg is not the same as image.JPG, or IMAGE.JPG.  This would be especially apparent if things showed up normally when you tested locally on your computer, but things did not show up when you uploaded and ran the survey on your web server.
answered Nov 11, 2011 by Brian McEwan Gold Sawtooth Software, Inc. (37,410 points)
...