Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Strange error while uploading a survey on a database

Hi All,

I have the following issue when I try to upload a survey using Web Server Management -> Self Hosting. Using SSI Web 8.4.8. It appears right after :

"Checking database for survey name conflicts...failed."

I see the following error with the code below in the popupbox instead of regular error message:

"An error occurred while checking remote survey path for uploading.

"; if ($__juv) { ($__juv, $__juw, $__jux, $__jur) = authlib8_4_8::_boa(0); if ($__jur) { print "Error: " . $__juw; if ($__jux) { print "\n\nSystem Error: " . $__jux; } $__jus = 1; } } else { print "Error: " . $__juw; if ($__jux) { print "\n\nSystem Error: " . $__jux; } $__jus = 1; } if (!$__jus) { print "Success: "; } print "



I am able to upload the same survey on a different server, not sure why this isn't working.


Regards,
Kaloyan
asked Jun 20, 2018 by KaloyanT (315 points)

1 Answer

0 votes
Please make sure that the server is set up to execute the Perl scripts correctly.

I would recommend that you upload the simple test Perl scripts that install with SSI Web.  The first one is called test1.pl and can be found in the installation folder which will be similar to the following:

C:\Program Files (x86)\Sawtooth Software\SSI Web 8.4.8\User Resources

Upload it to the cgi-bin folder and, if using a Linux server, set the execute permissions.

If the server is set up correctly, then going to the script in a web browser will print a success message.  If not, the script itself may be shown in the web browser instead.

Regards,

David Squire
answered Jun 20, 2018 by David Squire Silver Sawtooth Software, Inc. (5,730 points)
...