Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Format attribute levels in CBC

Hi again,
i still haven't discovered the way to format the attributes' levels of my choice task.
I use Sawtooth 8.4.8, and an experiment consists of: Free Format and CBC Random Question.
At the moment, my experiments, which consists of 3 choices (including the none option) are very long due to very narrow columns. This picture will dishearten the respondent to answer because he must read through a whole column, whereas if the column was wider then, the attributes' levels would be more obvious to see them, and select quicker.
I have searched through the 'Help' button, through youtube, through Forum and i still haven't a clear solution.
i don't believe that is such a complicated issue.
Is anybody aware of how can i solve this problem?
Should i use html?
If yes, then what is the code?
Is any assistance through Sawtooth?
I am looking anxiously to receive a good reply!
asked Mar 11, 2018 by iralexia14 (420 points)
Ok. But i have already 'played' with these, and the question width as well as attributes' column width has been fixed. The three next columns which have the attributes' level have the problem. They are too narrow. If i change cell padding, then they will change ALL cells, but i want to change ONLY the columns with the attributes' level and the 'None Option'
Thank you
If the built-in settings are proving insufficient, it might be time to try some more direct CSS.  Try putting code like this in your CBC's question text somewhere:

#[% QuestionName() %]_div .inner_table > tbody > tr > td:not(:first-child) {
    width: 250px;

That "250" can be changed to reflect your desired width.
Thank you, i used the code that you sent it to me, i entered it into the 'Footer'  of the Question/text tab but still no success?
Is it maybe somewhere the solution? I mean is it maybe at the point where i write the attribute levels? that is on the 2nd tab?
The footer is where I put the code in my testing.  In addition, I cleared out everything from my Format tab.  Finally, I tested my change using test survey rather than preview.  Can you try that?
THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Your solution to the original question

Please only use this to answer the original question. Otherwise please use comments.
Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

To avoid this verification in future, please log in or register.