Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Insecure dependency in require while running with -T switch

Hi

I started up a new centos 7. web server. I have Perl running ok, as I have done the Perl tests that were given on this site. I even have the database driver installed and working, but when uploading the survey and changing the files and folders to the correct file permissions, I get an internal 500 error.
When I read up on the Apache's error log, it says: Insecure dependency in require while running with -T switch at (eval 15) line 1.\n
This seems to be happening at ciwweb.pl.
I had this initially all working before until now.
On other surveys which had been loaded, I get: Error:Cannot load library: authlib8_4_8.pl

I am also not sure if maybe the Nagios installation might have had changed something here as well.

What am I doing wrong in terms of my server configuration? What could I have done wrong? Would anyone know what I can do to get this running again?
asked Jul 17 by JasonN

Your answer

Please only use this to answer the original question. Otherwise please use comments.
Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:

To avoid this verification in future, please log in or register.
...