Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Prior data reset after updating the survey directly in the server?

Hi,

I have a survey in our server and kinda did a test launch and it was working fine and the data are saved correctly. However, I did notice that when we updated one of the questions (e.g. Q20), all the previous data for this question disappeared for responses prior to the update. Is that a normal case? The data for questions which were not updated seem to be ok.
asked May 11, 2017 by anonymous

2 Answers

+1 vote
Dear User,

It seems you have changed the format of question. Like it was multi select question earlier and you changed to single coding.

Best practice in these scenario is to make a copy of question like Q20a and always preskip old question.

I think you can still locate those data from "old variables" which gets saved in raw database file. Support team can help you in this.

Regards,
Saurabh
answered May 11, 2017 by Saurabh Aggarwal Gold (30,680 points)
There was no change to the format of the question. It was a text(Numeric) type and the only change was to "Allow decimal answers".
0 votes
If you rename a question then it will look like the data collected before the rename is gone.  It is not really gone, but it will be moved into a different column.  Do you need the old data from before the question rename?

Dave Squire
answered May 11, 2017 by David Squire Silver Sawtooth Software, Inc. (5,730 points)
The question was not renamed
I think I found the reason. It was a free-format question and the variable type are all text (Numeric). All we did is to check the "Allow decimal answers" for each variable but we didn't change the variable type. Then all the prior answers for that question were all reset.
...