Have an idea?

Visit Sawtooth Software Feedback to share your ideas on how we can improve our products.

Not being able to open Data Management

I am using SSI Web 8.4.8 and previously was able to load Data Management but for some time now I am not. When I click on Data Management I got an error message saying: "Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

The type initializer for 'FarPOint.Win.Spread.DefaultSpreadSkins' threw an exception."

"See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box."

And the end of the file is (I removed the in-between messages but can post them):

"
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
"

I re-installed SSI Web and installed it again but the issue still appears. I tried enabling JIT Debugging (had to install MS Visual Studio 2017 Community Edition for that) and still doesn't work.

Did I remove needed files or something else happened?

Thanks in advance.
asked Apr 20, 2017 by KaloyanT (195 points)
retagged Apr 20, 2017 by Walter Williams

1 Answer

+2 votes
 
Best answer
I have not seen this error before.  I am out of the office today and will be the one to look at this issue.  I will be able to look into the problem on Monday.  Would you be able to send an email to support@sawtoothsoftware.com so I have your contact information for Monday?

What happens when you click Continue?  Do things work properly or does the View/Edit Data grid not load correctly?

Thanks,
Jon
answered Apr 21, 2017 by Jon Heaton Silver Sawtooth Software, Inc. (7,330 points)
selected Apr 24, 2017 by KaloyanT
Sure Jon. I'll send an email.

Cheers,
Kaloyan T.
Thanks for the help, Jon. Turns out that I was using Region->Language->English(Europe) for my language settings which was not supported by the framework. So using English(United States) or English(United Kingdom) works fine.
...