SSI Web: Apache doesn't seem to be running properly

Hi all,

I'll try to describe my issues the best that I can. I'm running SSI Web 7.0.26 (demo) on Windows 7 64 bits. While doing the "Getting Started: 45-Minute Tour of SSI Web", I tried to test the survey locally by clicking in the "Teste the Survey Locally" button. However, it doesn't seem to work, since the Apache process only runs for a brief period of time (some seconds) and then suddenly it stops (I repeatedly saw that happening through Windows Task Manager). I've tried to start Apache manually, changed the port, I even initially thought it was happening due to the proxy settings in Chrome, I even tried to open the pages in Internet Explorer, but nothing has changed. Also, when I try to reset  the test data, the following error pops up:

"Unable to reset test data due to the following error:

Local Test Server is not running. Please check the settings under the Test menu."

I've searched this forum and found nothing similar to this error. The majority of my day was spent trying to fix this. If someone can help me, or have a hint, I'd really appreciate to read it. Besides reinstalling SSI Web, I don't have nothing more in mind to do...

Many thanks,
João
asked Mar 6, 2012 by João Fernandes (1,296 points)

2 Answers

+2 votes
you might want to check apache logs as well.. these should be located in
c:\users\XXXXXXX\AppData\Roaming\Sawtooth Software, Inc\SSI Web\LocalWeb\logs\
perhaps they can shed light on why apache shuts down.

By the way, do you have IIS or any other web server configured to listen on port 80? That could be a reason for apache to terminate I guess...
answered Mar 7, 2012 by Bahadir Ozkurt Gold (10,016 points)
Thanks for the tip, I eventually will use your help!

Anyway, I can confirm that in 7.0.26 Apache doesn't work at all (not even with the cable unplugged...), which is tricky 'cause the key I'll use will be for this version. Not even changing the port (since by default version 8.0 uses 61501 and 7.0.26 uses 61499) makes it to function.

This is becoming a big mystery to me...
A slight improvement: I was able to replicate version 8.0 behaviour (with the network cable unplugged it works, plugged doesn't works) in version 7.0.26. What have I made? I've tried using again a Windows user account without international characters in the name. I've done this before, as I have mentioned in the previous posts, with no results, so I don't really know what (if anything) has changed in order to function this time.

Though, I'm still having issues when I'm connected to the web, and I don't really know why, since I'm accessing localhost. It seems related to the proxy present in this network, but I think that it is (at least) strange.

If anyone has a hint, please let me know.

Thank you all,
João
are you sure your browser does not have any proxy configuration? normally when defining a proxy in the browser, one would set the browser to bypass proxy for "localhost". perhaps this needs to be explicitly defined.

another thing is that on windows the whole system follows the network settings as defined by IE (if I recall correctly).

finally just open a  command prompt and "ping localhost", what do you get?
Bahadir: many thanks for your reply, it finally solved my problem! :] I had already had changed proxy settings in Chrome before, with no success. The fact is, I didn't tried it since I got version 7.0.26 to work (cable disconnected) yesterday. I was just about to configure my wireless connection when I gave another try to the proxy settings.

Now it is finally working. I just unchecked "Automatically detect settings" option and checked both options inside the "Proxy server" box.

Thank you all for your replies,
João
(also, I had already tried before the ping localhost @ command prompt and it was working as expected)
+1 vote
Make sure that the Apache program is ok to run in your firewall settings.  Frequently Windows will prompt for processes to have access to ports.  If your firewall is turned up to high or you have allowed Apache an exception in your firewall, this might be the problem.
answered Mar 6, 2012 by Mike Lodder Silver Sawtooth Software, Inc. (6,712 points)
If you use Windows firewall, look here:

Control Panel\All Control Panel Items\Windows Firewall\Allowed Programs
...